Selenium WebDriver no longer working with Firefox after Firefox update


(James) #1

Hi All,

Last night my Firefox automatically updated to version 56.0, and now I cannot execute any of my WebDriver test cases - when Firefox opens I get a message that states ‘Accessibility support is partially disabled due to compatibility issues with new Firefox features.’ The test is not run, and Selenium reports the error ‘System.InvalidOperationException: timeouts.’

I found this page which suggests restarting Firefox to enable accessibility features, or manually forcing it via about:config: Link

I have tried restarting and still no luck, and I cannot find browser.tabs.remote.force-enable in my about:config.

Had anybody else found a solution to this, or do I have to rollback to an older version of Firefox?

Many thanks,

sad_muso


(James) #2

UPDATE: Think I have fixed it by updating geckodriver to v0.19.0 which works with WebDriver 3.6.0 and Firefox 56.0


(Bob) #3

I haven’t tried the gecko update, but you can definitely download and install a pre-55 version of firefox and adjust ‘auto-update’ to prompt you. I have 2 instances of firefox now; the current version which I keep updated, and the pre-55 version, which is static. That’s obviously not a long-term solution here, but it does allow you to utilize the Selenium IDE.